it-roy-ru.com

Могу ли я установить XCode 7.3 на OS X 10.10 Yosemite?

Я не могу обновить свою OS X до 10.11 по причинам ....... XCode 7.3, кажется, первый XCode, который не совместим с Yosemite 10.10.

Кому-нибудь удалось заставить XCode 7.3 работать на Yosemite? (Какое важное обновление для XCode имеет имеет , чтобы сделать его несовместимым с Yosemite?)

12
Thyselius

К сожалению нет, вы не можете.

Вам нужна OS X 10.11 или более поздняя версия (El Capitan), начиная с 21 марта.

Таким образом, вы либо обновляетесь с Yosemite до El Capitan, либо придерживаетесь своего текущего Xcode.

Важный? Я скажу не так уж много ... iOS 9.3 и Swift 2.2, если вы любите ... С остальными ОС. Остальное в значительной степени то же самое, это не главное обновление.

11
Helen Wood

Если вы находитесь здесь, потому что вы обновили свое устройство (iPhone, Apple TV и т.д.) И больше не можете экспортировать свои приложения на это обновленное устройство, существует обходной путь!

На самом деле вы можете скопировать новейшую версию iOS XCode SDK из более новой версии XCode в вашу старую версию XCode.

1 Переименуйте свой старый XCode.app в XCode7.app и установите последнюю версию XCode (да, у вас может быть несколько версий).

2 Захватите папку в новой папке содержимого пакета XCode: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.3 \ 

И добавьте его там же, где и версия XCode 7.3 или 8.2/Applications/Xcode7.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

Перезапустите XCode, и вы сможете продолжать работать!

0
Thyselius