it-roy-ru.com

Развертывание в Windows Phone 10 завершается неудачно в Visual Studio

Так много всего произошло, что я не знаю, с чего начать. Серьезно, разве это не должно быть проще?

Правка: Кто-то здесь знает, как я могу связаться с Microsoft, чтобы сказать это? Или даже, кто-то может рассказать им об этой проблеме?

У меня последний рабочий стол Windows 10, а также Windows Phone 10.0.10512.1000. Я установил Visual Studio 2015 с инструментами для разработки универсальных приложений (а также 8.1). У меня Lumia 730.

Поэтому я подключил свой телефон с помощью USB-кабеля. Все хорошо, телефон распознается, и я могу перемещаться по папкам.

Затем я запустил Visual Studio 2015 и создал пустое универсальное приложение. Скомпилировал и попытался развернуть. Теперь это происходит со мной: Visual Studio зависает на несколько мгновений. В конце концов я получаю сообщение об ошибке, что устройство не найдено (DEP6200).

Я уже пробовал десятки решений:

  • отключение от Wi-Fi в моем ноутбуке и моем телефоне
  • перезапуск службы IpOverUsbSvc
  • перезагрузка компьютера и телефона
  • удаление устройств в диспетчере устройств
  • Регистрация и отмена регистрации телефона (иногда это работает)
  • Все вышеперечисленное с разблокированным экраном телефона
  • отключение Hyper-V
  • отключение брандмауэра
  • Другие решения, которые с треском провалились

Я также пытался использовать эти инструменты Windows Phone Developer Power Tools. Когда я пытаюсь использовать его, он просит меня установить какой-то "Пакет обновления Phone Tools", но когда я пытаюсь это сделать, он говорит, что операция не удалась, а также показывает строку сообщения NRE (ссылка на объект не установлена ​​на экземпляр объекта).

Я могу без проблем просматривать папки телефона. Я пытался переустановить драйверы ... я попробовал все. 

Это довольно грустно.

Ребята, вы можете придумать что-нибудь еще, чтобы проверить?

Правка: Я тестировал это приложение, прежде чем делать все это: https://blogs.windows.com/buildingapps/2015/07/09/just-released-windows-10-application-deployment-tool/

И это сработало. Если это так, развертывание Windows Phone 10 через Visual Studio уже работает или нам придется подождать еще немного?

Edit2: после внесения некоторых изменений в манифест моего приложения и выбора конфигурации «ARM», теперь я получаю следующее:

1>Deploying to SD Card...
1>Updating the layout...
1>Copying files: Total <1 mb to layout...
1>Checking whether required frameworks are installed...
1>Framework: Microsoft.NET.CoreRuntime.1.0/ARM, app package version 1.0.23117.0 is not currently installed.
1>Framework: Microsoft.VCLibs.140.00.Debug/ARM, app package version 14.0.23019.0 is not currently installed.
1>Installing missing frameworks...

Но это просто остается там. Он застрял и остается там навсегда. По крайней мере, я получил некоторую информацию ... Это более или менее те же шаги, что WinAppDeployCmd делает, но приложение командной строки делает это успешно.

29
Ricardo Pieper

Каким-то образом проблема была решена. Я создал новый проект и сделал это:

1 - попробуйте отключить режим разработчика на своем телефоне. Какое неожиданное развитие!  

2 - отключить "обнаружение телефона" Я не знаю названия этой конфигурации на английском (так как мой телефон на португальском). Так, на всякий случай. 

3 - Выберите правильную архитектуру. Это очевидно, верно? В моем случае ARM. Если вы попытаетесь выполнить развертывание с x86 или x64, это должно привести к ошибке. Для меня это не так.

Отныне вы должны иметь возможность развертывать приложения как в режиме разработчика, так и в режиме без разработчика. Это просто работает, как-то. И это может не сработать для вас, извините. Я думаю, что мне повезло.

Работало даже после перезагрузки. Таким образом, решение «довольно твердое» (во вселенной, где желатин довольно твердый).

7
Ricardo Pieper

На тот случай, если кто-то все еще сталкивается с этой проблемой, у меня было нечто очень похожее с моим профессиональным обновлением 1 для Visual Studio 2015, но я даже не смог развернуть его на эмуляторе ........ Проблема исчезла после того, как я обновил до Visual Studio 2013 с обновлением 3 ,.

0
user1439978

У меня Lumia 950 xl, с установленной windows 10, юбилейная версия. У меня была та же проблема, и я решил включить «Обнаружение устройства» и «Портал устройства», а также включить «Режим разработчика». 

Я считаю, что единственной необходимой опцией было «Обнаружение устройства»!

0
Snorvarg

У меня такая же проблема. Я попытался исправить комментарий и пошел к диспетчеру устройств. 

Под USB-устройствами были перечислены три Lumia 920.

  1. Я выбрал второй и нажал на удаление.

  2. В конце он попросил меня перезагрузить компьютер. Я нажал на НЕТ.

(Когда я удалил первый или третий, он не спрашивал меня об этом) . Затем ошибка исчезла (теперь появляется другая распространенная ошибка (HRESULT: 0x80073CF6))

0
user5884620