it-roy-ru.com

Невозможно установить бордюрный камень

Это дает мне ошибку

 gem install curb
Building native extensions.  This could take a while...
ERROR:  Error installing curb:
    ERROR: Failed to build gem native extension.

        /usr/bin/Ruby1.9.1 extconf.rb
/usr/lib/Ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError)
    from /usr/lib/Ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from extconf.rb:1:in `<main>'


Gem files will remain installed in /home/user1/.rvm/gems/Ruby-1.9.3-p392/gems/curb-0.8.3 for inspection.
Results logged to /home/user1/.rvm/gems/Ruby-1.9.3-p392/gems/curb-0.8.3/ext/gem_make.out

список rvm

rvm rubies

   Ruby-1.9.3-p385 [ broken ]
=* Ruby-1.9.3-p392 [ x86_64 ]
   Ruby-2.0.0-p0 [ x86_64 ]

# => - current
# =* - current && default
#  * - default


[email protected]:~$ Sudo apt-get install libcurl3 libcurl3-gnutls libcurl4-openssl-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcurl3-gnutls is already the newest version.
libcurl4-openssl-dev is already the newest version.
libcurl3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Как мне это исправить?

20
Alan Coromano

Насколько я помню, он использует curl libs для компиляции 

Так что вам нужно будет установить curl dev libs Попробуйте установить 

Sudo apt-get install libcurl4-openssl-dev

или же

Sudo apt-get install libcurl4-gnutls-dev
66
Pritesh Jain

На Fedora я сделал Sudo yum install curl-devel, а затем сделал gem install curb, и это помогло мне

6
Joseph N.

В Ubuntu 14.04, кроме пакетов libcurl, упомянутых PriteshJ, я также должен установить пакет Ruby-dev, чтобы он работал:

Sudo apt-get установить Ruby-dev

2
Trần Việt Hoàng

В Ubuntu зависимости могут быть удовлетворены путем установки следующих пакетов:

$ Sudo apt-get install libcurl3 libcurl3-gnutls libcurl4-openssl-dev

На RedHat:

$ Sudo yum install Ruby-devel libcurl-devel openssl-devel
0
Moin Haidar

У меня недавно была эта проблема в образе докера ubuntu 14.04 с ограничением 0.9.0, и я решил ее, установив libgmp-dev (в дополнение к уже упомянутым предложениям на странице ограничения: libcurl3 libcurl3-gnutls libcurl4-openssl-dev).

0
Matt Konda