it-roy-ru.com

Произошла ошибка при установке json (1.8.1), и Bundler не может продолжить - Rails

Произошла ошибка при установке json (1.8.1), и Bundler не может продолжить. Убедитесь, что gem install json -v '1.8.1' успешен перед объединением. xcrun: ошибка: неверный путь активного разработчика (/ Library/Developer/CommandLineTools), отсутствует xcrun в:/Library/Developer/CommandLineTools/usr/bin/xcrun

сделать не удалось, код выхода 1

Я знаю, что это уже было опубликовано, но я попытался обновить пакет, установить пакет и поместить файл gem в мой файл gem и установить пакет, но ничего не работает из других ответов.

идеи?

6
thatsmesofia

Запуск "обновления пакета" работал для меня.

21
Waqas

Вы можете попробовать bundle update && bundle install.
Подробнее об этом здесь .

10
sonlexqt

Более безопасный подход может быть: 
bundle update json 
bundle install

6
Edgar Aviles

Запустите следующее в терминале:

xcode-select --install

Источник

3
phil pirozhkov

Удалите старый файл Gemfile.lock и снова запустите bundle. Должна быть установлена ​​более новая версия json.

1
Sirajus Salayhin

В Ruby 2.4.4 используйте версию Backup 5.0.0.beta.1. 

gem install backup -v5.0.0.beta.1

Это решило проблему для меня

1
kgehlot