it-roy-ru.com

Gemfile.lock содержит конфликты слияния

Я просто запустил git Push Origin master и получил эту ошибку после попытки запустить Rails s:

Your Gemfile.lock contains merge conflicts.
Run `git checkout HEAD -- Gemfile.lock` first to get a clean lock.

Ни git checkout HEAD --Gemfile.lock, bundle, bundle install, ни bundle update не помогают решить эту проблему. Кто-нибудь знает, что делать, чтобы это исправить?

Gemfile:

source 'https://rubygems.org'

Ruby "2.1.2"
gem 'devise'

gem 'twilio-Ruby', '~> 3.12'

# Bundle Edge Rails instead: gem 'Rails', github: 'Rails/rails'
gem 'Rails', '4.2.0.beta2'
# Use postgresql as the database for Active Record
gem 'pg'
# Use SCSS for stylesheets
gem 'sass-Rails', '~> 5.0.0.beta1'
# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'
# Use CoffeeScript for .js.coffee assets and views
gem 'coffee-Rails', '~> 4.0.0'
# See https://github.com/sstephenson/execjs#readme for more supported runtimes

# Use jQuery as the JavaScript library
gem 'jquery-Rails', '~> 4.0.0.beta2'
# Turbolinks makes following links in your web application faster. Read more: https://github.com/Rails/turbolinks
gem 'turbolinks'
# Build JSON APIs with ease. Read more: https://github.com/Rails/jbuilder
gem 'jbuilder', '~> 2.0'
# bundle exec rake doc:Rails generates the API under doc/api.
gem 'sdoc', '~> 0.4.0', group: :doc


group :development, :test do
  # Call 'debugger' anywhere in the code to stop execution and get a debugger console
  gem 'pry-byebug'

  # Access an IRB console on exception pages or by using <%= console %> in views
  gem 'web-console', '~> 2.0.0.beta4'

  # Spring speeds up development by keeping your application running in the background. Read more: https://github.com/Rails/spring
  gem 'spring'
end

Gemfile.lock:

GEM
  remote: https://rubygems.org/
  specs:
    actionmailer (4.2.0.beta2)
      actionpack (= 4.2.0.beta2)
      actionview (= 4.2.0.beta2)
      activejob (= 4.2.0.beta2)
      mail (~> 2.5, >= 2.5.4)
      Rails-dom-testing (~> 1.0, >= 1.0.3)
    actionpack (4.2.0.beta2)
      actionview (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      rack (~> 1.6.0.beta)
      rack-test (~> 0.6.2)
      Rails-dom-testing (~> 1.0, >= 1.0.3)
      Rails-html-sanitizer (~> 1.0, >= 1.0.1)
    actionview (4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      builder (~> 3.1)
      erubis (~> 2.7.0)
      Rails-dom-testing (~> 1.0, >= 1.0.3)
      Rails-html-sanitizer (~> 1.0, >= 1.0.1)
    activejob (4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      globalid (>= 0.3.0)
    activemodel (4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      builder (~> 3.1)
    activerecord (4.2.0.beta2)
      activemodel (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      arel (>= 6.0.0.beta1, < 6.1)
    activesupport (4.2.0.beta2)
      i18n (>= 0.7.0.beta1, < 0.8)
      json (~> 1.7, >= 1.7.7)
      minitest (~> 5.1)
      thread_safe (~> 0.1)
      tzinfo (~> 1.1)
    addressable (2.3.6)
    arel (6.0.0.beta1)
    binding_of_caller (0.7.3.pre1)
      debug_inspector (>= 0.0.1)
    buftok (0.2.0)
    builder (3.2.2)
    byebug (3.5.1)
      columnize (~> 0.8)
      debugger-linecache (~> 1.2)
      slop (~> 3.6)
    coderay (1.1.0)
    coffee-Rails (4.0.1)
      coffee-script (>= 2.2.0)
      railties (>= 4.0.0, < 5.0)
    coffee-script (2.3.0)
      coffee-script-source
      execjs
    coffee-script-source (1.8.0)
    columnize (0.8.9)
    debug_inspector (0.0.2)
    debugger-linecache (1.2.0)
    equalizer (0.0.9)
    erubis (2.7.0)
    execjs (2.2.2)
    faraday (0.9.0)
      multipart-post (>= 1.2, < 3)
    globalid (0.3.0)
      activesupport (>= 4.1.0)
    hike (1.2.3)
    http (0.6.2)
      http_parser.rb (~> 0.6.0)
    http_parser.rb (0.6.0)
    i18n (0.7.0.beta1)
    jbuilder (2.2.2)
      activesupport (>= 3.0.0, < 5)
      multi_json (~> 1.2)
    jquery-Rails (4.0.0.beta2)
      Rails-dom-testing (~> 1.0)
      railties (>= 4.2.0.beta, < 5.0)
      thor (>= 0.14, < 2.0)
    json (1.8.1)
    jwt (1.0.0)
    loofah (2.0.1)
      nokogiri (>= 1.5.9)
    mail (2.6.1)
      mime-types (>= 1.16, < 3)
    memoizable (0.4.2)
      thread_safe (~> 0.3, >= 0.3.1)
    method_source (0.8.2)
    mime-types (2.4.2)
    mini_portile (0.6.0)
    minitest (5.4.2)
    multi_json (1.10.1)
    multipart-post (2.0.0)
    naught (1.0.0)
    nokogiri (1.6.3.1)
      mini_portile (= 0.6.0)
    pg (0.17.1)
    pry (0.10.1)
      coderay (~> 1.1.0)
      method_source (~> 0.8.1)
      slop (~> 3.4)
    pry-byebug (2.0.0)
      byebug (~> 3.4)
      pry (~> 0.10)
    rack (1.6.0.beta)
    rack-test (0.6.2)
      rack (>= 1.0)
    Rails (4.2.0.beta2)
      actionmailer (= 4.2.0.beta2)
      actionpack (= 4.2.0.beta2)
      actionview (= 4.2.0.beta2)
      activejob (= 4.2.0.beta2)
      activemodel (= 4.2.0.beta2)
      activerecord (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      bundler (>= 1.3.0, < 2.0)
      railties (= 4.2.0.beta2)
      sprockets-Rails (~> 3.0.0.beta1)
    Rails-deprecated_sanitizer (1.0.3)
      activesupport (>= 4.2.0.alpha)
    Rails-dom-testing (1.0.4)
      activesupport (>= 4.2.0.beta, < 5.0)
      nokogiri (~> 1.6.0)
      Rails-deprecated_sanitizer (>= 1.0.1)
    Rails-html-sanitizer (1.0.1)
      loofah (~> 2.0)
    railties (4.2.0.beta2)
      actionpack (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      rake (>= 0.8.7)
      thor (>= 0.18.1, < 2.0)
    rake (10.3.2)
    rdoc (4.1.2)
      json (~> 1.4)
    sass (3.4.6)
    sass-Rails (5.0.0.beta1)
      railties (>= 4.0.0, < 5.0)
      sass (~> 3.2)
      sprockets (~> 2.12)
      sprockets-Rails (>= 2.0, < 4.0)
    sdoc (0.4.1)
      json (~> 1.7, >= 1.7.7)
      rdoc (~> 4.0)
    simple_oauth (0.2.0)
    slop (3.6.0)
    spring (1.1.3)
    sprockets (2.12.2)
      hike (~> 1.2)
      multi_json (~> 1.0)
      rack (~> 1.0)
      tilt (~> 1.1, != 1.3.0)
    sprockets-Rails (3.0.0.beta1)
      actionpack (>= 4.0)
      activesupport (>= 4.0)
      sprockets (~> 2.8)
    thor (0.19.1)
    thread_safe (0.3.4)
    tilt (1.4.1)
    turbolinks (2.4.0)
      coffee-Rails
<<<<<<< HEAD
    twilio-Ruby (3.13.1)
      builder (>= 2.1.2)
      jwt (~> 1.0.0)
      multi_json (>= 1.3.0)
=======
    Twitter (5.11.0)
      addressable (~> 2.3)
      buftok (~> 0.2.0)
      equalizer (~> 0.0.9)
      faraday (~> 0.9.0)
      http (~> 0.6.0)
      http_parser.rb (~> 0.6.0)
      json (~> 1.8)
      memoizable (~> 0.4.0)
      naught (~> 1.0)
      simple_oauth (~> 0.2.0)
>>>>>>> 97cefa491ac4217bdee8557c84f3657355f9b049
    tzinfo (1.2.2)
      thread_safe (~> 0.1)
    uglifier (2.5.3)
      execjs (>= 0.3.0)
      json (>= 1.8.0)
    web-console (2.0.0.beta4)
      activemodel (~> 4.0)
      binding_of_caller (= 0.7.3.pre1)
      railties (~> 4.0)
      sprockets-Rails (>= 2.0, < 4.0)

PLATFORMS
  Ruby

DEPENDENCIES
  coffee-Rails (~> 4.0.0)
  jbuilder (~> 2.0)
  jquery-Rails (~> 4.0.0.beta2)
  pg
  pry-byebug
  Rails (= 4.2.0.beta2)
  sass-Rails (~> 5.0.0.beta1)
  sdoc (~> 0.4.0)
  spring
  turbolinks
<<<<<<< HEAD
  twilio-Ruby (~> 3.12)
=======
  Twitter
>>>>>>> 97cefa491ac4217bdee8557c84f3657355f9b049
  uglifier (>= 1.3.0)
  web-console (~> 2.0.0.beta4)
9
Lauren F

Таким образом, ваш Gemfile.lock полон неразрешенных конфликтов слияния.

 GEM
  remote: https://rubygems.org/
  specs:
    actionmailer (4.2.0.beta2)
      actionpack (= 4.2.0.beta2)
      actionview (= 4.2.0.beta2)
      activejob (= 4.2.0.beta2)
      mail (~> 2.5, >= 2.5.4)
      Rails-dom-testing (~> 1.0, >= 1.0.3)
    actionpack (4.2.0.beta2)
      actionview (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      rack (~> 1.6.0.beta)
      rack-test (~> 0.6.2)
      Rails-dom-testing (~> 1.0, >= 1.0.3)
      Rails-html-sanitizer (~> 1.0, >= 1.0.1)
    actionview (4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      builder (~> 3.1)
      erubis (~> 2.7.0)
      Rails-dom-testing (~> 1.0, >= 1.0.3)
      Rails-html-sanitizer (~> 1.0, >= 1.0.1)
    activejob (4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      globalid (>= 0.3.0)
    activemodel (4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      builder (~> 3.1)
    activerecord (4.2.0.beta2)
      activemodel (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      arel (>= 6.0.0.beta1, < 6.1)
    activesupport (4.2.0.beta2)
      i18n (>= 0.7.0.beta1, < 0.8)
      json (~> 1.7, >= 1.7.7)
      minitest (~> 5.1)
      thread_safe (~> 0.1)
      tzinfo (~> 1.1)
    addressable (2.3.6)
    arel (6.0.0.beta1)
    binding_of_caller (0.7.3.pre1)
      debug_inspector (>= 0.0.1)
    buftok (0.2.0)
    builder (3.2.2)
    byebug (3.5.1)
      columnize (~> 0.8)
      debugger-linecache (~> 1.2)
      slop (~> 3.6)
    coderay (1.1.0)
    coffee-Rails (4.0.1)
      coffee-script (>= 2.2.0)
      railties (>= 4.0.0, < 5.0)
    coffee-script (2.3.0)
      coffee-script-source
      execjs
    coffee-script-source (1.8.0)
    columnize (0.8.9)
    debug_inspector (0.0.2)
    debugger-linecache (1.2.0)
    equalizer (0.0.9)
    erubis (2.7.0)
    execjs (2.2.2)
    faraday (0.9.0)
      multipart-post (>= 1.2, < 3)
    globalid (0.3.0)
      activesupport (>= 4.1.0)
    hike (1.2.3)
    http (0.6.2)
      http_parser.rb (~> 0.6.0)
    http_parser.rb (0.6.0)
    i18n (0.7.0.beta1)
    jbuilder (2.2.2)
      activesupport (>= 3.0.0, < 5)
      multi_json (~> 1.2)
    jquery-Rails (4.0.0.beta2)
      Rails-dom-testing (~> 1.0)
      railties (>= 4.2.0.beta, < 5.0)
      thor (>= 0.14, < 2.0)
    json (1.8.1)
    jwt (1.0.0)
    loofah (2.0.1)
      nokogiri (>= 1.5.9)
    mail (2.6.1)
      mime-types (>= 1.16, < 3)
    memoizable (0.4.2)
      thread_safe (~> 0.3, >= 0.3.1)
    method_source (0.8.2)
    mime-types (2.4.2)
    mini_portile (0.6.0)
    minitest (5.4.2)
    multi_json (1.10.1)
    multipart-post (2.0.0)
    naught (1.0.0)
    nokogiri (1.6.3.1)
      mini_portile (= 0.6.0)
    pg (0.17.1)
    pry (0.10.1)
      coderay (~> 1.1.0)
      method_source (~> 0.8.1)
      slop (~> 3.4)
    pry-byebug (2.0.0)
      byebug (~> 3.4)
      pry (~> 0.10)
    rack (1.6.0.beta)
    rack-test (0.6.2)
      rack (>= 1.0)
    Rails (4.2.0.beta2)
      actionmailer (= 4.2.0.beta2)
      actionpack (= 4.2.0.beta2)
      actionview (= 4.2.0.beta2)
      activejob (= 4.2.0.beta2)
      activemodel (= 4.2.0.beta2)
      activerecord (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      bundler (>= 1.3.0, < 2.0)
      railties (= 4.2.0.beta2)
      sprockets-Rails (~> 3.0.0.beta1)
    Rails-deprecated_sanitizer (1.0.3)
      activesupport (>= 4.2.0.alpha)
    Rails-dom-testing (1.0.4)
      activesupport (>= 4.2.0.beta, < 5.0)
      nokogiri (~> 1.6.0)
      Rails-deprecated_sanitizer (>= 1.0.1)
    Rails-html-sanitizer (1.0.1)
      loofah (~> 2.0)
    railties (4.2.0.beta2)
      actionpack (= 4.2.0.beta2)
      activesupport (= 4.2.0.beta2)
      rake (>= 0.8.7)
      thor (>= 0.18.1, < 2.0)
    rake (10.3.2)
    rdoc (4.1.2)
      json (~> 1.4)
    sass (3.4.6)
    sass-Rails (5.0.0.beta1)
      railties (>= 4.0.0, < 5.0)
      sass (~> 3.2)
      sprockets (~> 2.12)
      sprockets-Rails (>= 2.0, < 4.0)
    sdoc (0.4.1)
      json (~> 1.7, >= 1.7.7)
      rdoc (~> 4.0)
    simple_oauth (0.2.0)
    slop (3.6.0)
    spring (1.1.3)
    sprockets (2.12.2)
      hike (~> 1.2)
      multi_json (~> 1.0)
      rack (~> 1.0)
      tilt (~> 1.1, != 1.3.0)
    sprockets-Rails (3.0.0.beta1)
      actionpack (>= 4.0)
      activesupport (>= 4.0)
      sprockets (~> 2.8)
    thor (0.19.1)
    thread_safe (0.3.4)
    tilt (1.4.1)
    turbolinks (2.4.0)
      coffee-Rails
    twilio-Ruby (3.13.1)
      builder (>= 2.1.2)
      jwt (~> 1.0.0)
      multi_json (>= 1.3.0)

    Twitter (5.11.0)
      addressable (~> 2.3)
      buftok (~> 0.2.0)
      equalizer (~> 0.0.9)
      faraday (~> 0.9.0)
      http (~> 0.6.0)
      http_parser.rb (~> 0.6.0)
      json (~> 1.8)
      memoizable (~> 0.4.0)
      naught (~> 1.0)
      simple_oauth (~> 0.2.0)
    tzinfo (1.2.2)
      thread_safe (~> 0.1)
    uglifier (2.5.3)
      execjs (>= 0.3.0)
      json (>= 1.8.0)
    web-console (2.0.0.beta4)
      activemodel (~> 4.0)
      binding_of_caller (= 0.7.3.pre1)
      railties (~> 4.0)
      sprockets-Rails (>= 2.0, < 4.0)

PLATFORMS
  Ruby

DEPENDENCIES
  coffee-Rails (~> 4.0.0)
  jbuilder (~> 2.0)
  jquery-Rails (~> 4.0.0.beta2)
  pg
  pry-byebug
  Rails (= 4.2.0.beta2)
  sass-Rails (~> 5.0.0.beta1)
  sdoc (~> 0.4.0)
  spring
  turbolinks
  twilio-Ruby (~> 3.12)
  Twitter
  uglifier (>= 1.3.0)
  web-console (~> 2.0.0.beta4)

Я только что удалил конфликты. Вы должны быть в состоянии добавить приведенный выше код в ваш Gemfile.lock, и все должно быть хорошо.

Когда вы видите это:

<<<<<<< HEAD
  twilio-Ruby (~> 3.12)
=======
  Twitter
>>>>>>> 97cefa491ac4217bdee8557c84f3657355f9b049

в вашем коде это означает, что у вас был конфликт слияния.

4
Joel

Драгоценные камни, которые использовались в любой ветке, должны были быть добавлены в Gemfile. Поэтому вы можете проверить самый последний чистый Gemfile.lock с:

git checkout HEAD -- Gemfile.lock

А затем запустите bundle install, чтобы установить необходимые гемы и восстановить Gemfile.lock.

12
Gideon Rosenthal

Вы можете редактировать Gemfile.lock, чтобы избавиться от конфликтов вручную

http://rubyinrails.com/2013/12/what-is-gemfile-lock/

0
Zach Smith