it-roy-ru.com

RuntimeException Расширение Zip PHP не установлено

Я новичок в Linux, я только что установил composer и ​​laravel ...

но когда я запускаю laravel new project, я получаю следующую ошибку:

[RuntimeException]
The Zip PHP extension is not installed. Please install it and try again.

Я не знаю, как установить это расширение ...

пожалуйста помоги

9
Amjad

Попробуйте ввести в командной строке:

Sudo apt-get install php7.0-Zip

Подтвердите с любого маршрута с помощью:

dd(get_loaded_extensions());

Это сработало для меня, удачи.

14
Devin Norgarb

для php 7.0

Sudo apt-get install php7.0-Zip

для php 7.1

Sudo apt-get install php7.1-Zip

и так далее!

5
Harry

Я получил ту же проблему и попытался установить расширение с помощью команды Sudo apt install php7.0-Zip, но все равно получил ту же ошибку. Я наконец решил это с Sudo apt install php-Zip

3
Robert Odoch

Я использовал php7.0-zts.
Решение было удалить все пакеты ZTS и вернуться к обычным пакетам php7.0.

1
Aryeh Beitz