it-roy-ru.com

модель-> атрибуты в Yii2 всегда имеет значение NULL

У меня есть одна временная модель, как viewModel. В моих действиях CRUD (например, actionCreate) я хочу получить эти данные viewModel и назначить их модели ActiveRecord. Я использовал код ниже, но мой атрибут объекта модели всегда показывает значение NULL для атрибутов:

$model = new _Users();
if ($model->load(Yii::$app->request->post())) {
    Yii::info($model->attributes,'test'); // NULL
    $attributesValue =[
            'title' => $_POST['_Users']['title'],
            'type' => $_POST['_Users']['type'],
        ];
    $model->attributes = $attributesValue;
    Yii::info($model->attributes,'test'); // NULL

    $dbModel = new Users();
    $dbModel->title = $model->title;
    $dbModel->type = $model->type . ' CYC'; // CYC is static type code
    Yii::info($dbModel->attributes,'test'); // NULL

    if ($dbModel->save()) {
            return $this->redirect(['view', 'id' => $dbModel->id]); // Page redirect to blank page
        }
}
else {
        return $this->render('create', [
            'model' => $model,
        ]);
}

Я думаю, что $ model-> load (Yii :: $ app-> request-> post ()) не работает, а атрибут объекта равен NULL. Это ошибка Yii2 или мой код неверный ??

13
b24

Если для вашего атрибута нет правил,$model->load()будет игнорировать те, которые не указаны в правилах модели.

Добавьте свои атрибуты в функцию правил

public function rules()
{
    return [
        ...
        [['attribute_name'], 'type'],
        ...
    ];
}
20
Jason G

Чтобы получить данные для отдельных атрибутов (db-fields) в yii2.0, вам нужно сделать следующее: 

echo $yourModel->getAttribute('email');
3
Amjad Ali Chauhdry

ActiveRecord $attributes является частной собственностью Использование $model->getAttribute(string)

1
Alex

Вы можете использовать следующие коды: 

$model = new _Users();
$model->attributes=Yii::$app->request->post('_Users');
$model->title= $model->title
$model->type = $model->type . ' CYC'; // CYC is static type code
#$model->sampleAttribute='Hello World';
1
Mahmut Aydın

Вы должны удалить все открытые свойства ( заголовок, тип и т.д.) В вашей модели _User, и $model->attributes = $post будет работать правильно.

0
Alexander

Я также столкнулся с той же проблемой, я добавил свои атрибуты в функцию правил, но также и ошибку. И я нашел причину этой проблемы. Это потому, что имя формы отправки в соответствующем файле представления не совпадает с именем модели, которое вы используете в контроллере

[controller file]:

$model=new SearchForm();

[view file]:

<input name="SearchForm[attribus]" ...

or 

[view file]:

<?= $form->field($model,'atrribus')->textInput()?>
0
soc