it-roy-ru.com

Зависимости - ошибка не установлена ​​(npm WARN необязательно Пропуск ОПЦИОНАЛЬНАЯ ЗАВИСИМОСТЬ: [email protected]^1.0.0 (node_modules\chokidar\node_modules\fsevents)

Я пытаюсь заставить работать веб-пакет в Visual Studio, но продолжаю сталкиваться с проблемой Dependencies - not installed. Я получаю эту ошибку в выводе:

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","Arch":"any"} (current: {"os":"win32","Arch":"x64"})

Я прочитал это пост и решение Скотта Хансельмана в здесь . То есть Я установил последний узел (7.0.0) + npm (3.10.8) и настроил Visual Studio на использование установки моего узла (это определенно используется, поскольку я вижу это в выходных данных: "C:\Program Files\nodejs\npm.CMD" install). 

Поэтому я следовал всему этому, но дело в том, что я все еще получаю это глупое not installed предупреждение в Visual Studio. Я делаю что-то не так или он работал в одной из версий, но больше не работает с последними узлами и nmp?

5
Ilya Chernomordik

Это предупреждение о том, что **fseventsd**.

это не ошибка.

это MAC OS Specified, работающий в windows илиLinuxпоказать это предупреждение, это единственная причина, по которой оно показывает это предупреждение, вы можете пропустить его.

4
Mark-VII

Используйте --no-option во всех средах, за исключением того, что OSX эффективно отключает причину предупреждения.

npm install --no-необязательный

Также вы можете изменить уровень журнала на error , чтобы вы не увидели предупреждение.

0
Josem