it-roy-ru.com

Poltergeist - отключение предупреждений JQMIGRATE

При запуске моего набора тестов с использованием poltergeist в качестве драйвера JavaScript я получаю следующие предупреждения:

JQMIGRATE: jQuery.fn.attr(selected) may use property instead of attribute
JQMIGRATE: jQuery.browser is deprecated

Можно ли их отключить?

18
alexs333

Минимизированная версия по умолчанию отключена:

<script src="http://code.jquery.com/jquery-migrate-1.2.1.min.js"></script>
26
Cherniv

Найдите jQuery.migrateMute = false в jquery-migrate.js и установите для него true

25
benchwarmer

После ответа от Benchwarmer это:

function custom_mute_jquery_migrator() {   
    echo '<script>jQuery.migrateMute = true;</script>';
}
add_action( 'wp_head', 'custom_mute_jquery_migrator' );
add_action( 'admin_head', 'custom_mute_jquery_migrator' );

Исправил это для меня . Спасибо @benchwarmer.

1
user382738

Доступна более новая минимизированная версия.

<script src="http://code.jquery.com/jquery-migrate-3.0.0.min.js"></script>
0
Sikandar Amla