it-roy-ru.com

Swagger..Не удается отобразить это определение В указанном определении не указано допустимое поле версии

Невозможно отобразить это определение. Предоставленное определение не укажите действительное поле версии.

Пожалуйста, укажите правильное поле версии Swagger или OpenAPI. Поддерживаемые Поля версии имеют чванство: «2.0» и те, которые соответствуют openapi: 3.0.n (например, openapi: 3.0.0).

Где мне нужно вставить правильную версию, чтобы остановить ошибку ниже . Редактор Swagger работает нормально, но при запуске определенного проекта я получаю эту ошибку. Впервые использую Swagger . Большое спасибо

1
Paddy Popeye

В вашем определении API отсутствует номер версии OpenAPI/Swagger, в данном случае "swagger": "2.0". Добавьте это в начале, вот так:

{
    "swagger": "2.0",

    "title" : "Music API Documentation",
    ...
2
Helen