it-roy-ru.com

Несовместимо с вашей операционной системой или архитектурой: [email protected]

Я использую Ubuntu 15.04. Во время выполнения следующей команды:

npm install fsevents

Я получаю следующую ошибку:

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: [email protected]
npm WARN [email protected] No repository field.

Кто-нибудь решил это?

51
randomuser

Я столкнулся с той же проблемой с этой зависимостью при создании другого приложения.

Просто ради знаний и для людей, которые не очень хорошо знакомы с NPM и, следовательно, не уверены, как будут вести себя их приложения: 

Поскольку fsevents является API в OS X позволяет приложениям регистрироваться для уведомлений об изменениях в данном дереве каталогов . Бег:

npm install --no-optional

Сделаем трюк, без недостатков.

82
Cezar Augusto

Это не ошибка, это просто предупреждение: это необязательная зависимость.

9
JMM

Вы можете указать npm не устанавливать необязательные зависимости по умолчанию с помощью командной строки:

npm config set optional false
3
Simon D

Я также столкнулся с этой ошибкой при установке Redux :

$ npm install --save react-redux
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: [email protected]

Проблема была решена путем добавления --no-optional (аргумент предотвратит установку необязательных зависимостей):

npm install --no-optional --save react-redux
            ^^^^^^^^^^^^^

И теперь он правильно установлен:

$ npm ls redux
[email protected] /home/me/projects/reduxproject
└── [email protected] 
0
fedorqui

У меня была такая же проблема с зависимостью. Пожалуйста, проверьте файл package.json, добавьте запись «typings»: «^ 0.8.1» в разделе devDependency. не забудьте добавить запятую раньше :) Надеюсь, что это решит проблему.

0
santosh bhoyar

Я нашел, если вы используете «пряжа добавить». Пряжа исключит, fsevents не выдаст ошибку.

0
Supa_dave72

Если вы получаете ERR! ПРЕДУПРЕЖДЕНИЕ. Вероятной причиной этой проблемы является то, что вы используете действительно устаревшую версию NPM.

Для меня я зашел на какой-то сервер, и мне было похоже «почему это не сработает?», Получая эту ошибку:

npm ERR! Linux 4.4.0-130-generic
npm ERR! argv "/home/william/.nvm/versions/node/v4.4.3/bin/node" "/home/william/.nvm/versions/node/v4.4.3/bin/npm" "install"
npm ERR! node v4.4.3
npm ERR! npm  v2.15.1
npm ERR! code EBADPLATFORM

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: [email protected]
npm ERR! notsup Valid OS:    darwin
npm ERR! notsup Valid Arch:  any
npm ERR! notsup Actual OS:   linux
npm ERR! notsup Actual Arch: x64

npm ERR! Please include the following file with any support request:
npm ERR!     /home/william/app/mcard-api/npm-debug.log

Оказывается, этот сервер (который я только недавно приобрел) работал под управлением npm 2.15.1. Я переустановил nvm, и nvm install --lts исправил это.

0
csga5000