it-roy-ru.com

java.lang.NoClassDefFoundError: org/glassfish/jersey/internal/inject/Binder при запуске Tomcat Server

Я создаю REST API на Java с Джерси и Maven. Я использовал Tomcat 9 в качестве моего сервера. Все работает нормально, пока я не попытался установить RestAssured,Hamcrest, и JUnit сегодня. Внезапно все мои конечные точки выбросили 500 внутренних ошибок сервера. Основной причиной ошибки 500 является Java.lang.NoClassDefFoundError: org/glassfish/jersey/internal/inject/Binder.

Что я сделал за 2 часа: 

  • Я пытался найти этот класс: org/glassfish/jersey/internal/inject/Binder в Google, но безрезультатно. 
  • Я пытался удалить RestAssured, Hamcrest и JUnit, но это не помогло. 

Эта проблема меня расстраивает. Есть идеи, почему произошли эти ошибки? Заранее спасибо!

Вот выдержка из журнала сервера:

SEVERE: выделить исключение для веб-приложения Джерси сервлета Java.lang.ClassNotFoundException: org.glassfish.jersey.internal.inject.Binder в org.Apache.catalina.loader.WebappClassLoaderBase.loadClass (WebappClassLoaderBase.Java:1275) в org.Apache.catalina.loader.WebappClassLoaderBase.loadClass (WebappClassLoaderBase.Java:1109) на org.glassfish.jersey.servlet.ServletContainer.init (ServletContainer.Java:178) на org.glassfish.jersey.servlet.ServletContainer.init (ServletContainer.Java:370) at javax.servlet.GenericServlet.init (GenericServlet.Java:158) в org.Apache.catalina.core.StandardWrapper.initServlet (StandardWrapper.Java:1183) в org.Apache.catalina.core.StandardWrapper.loadServlet (StandardWrapper.Java:1099) в org.Apache.catalina.core.StandardWrapper.allocate (StandardWrapper.Java:779) в org.Apache.catalina.core.StandardWrapperValve.invoke (StandardWrapperValve.Java:133) в org.Apache.catalina.core.StandardContextValve.invoke (StandardContextValve.Java:96) в org.Apache.catalina.authenticator.AuthenticatorBase.invoke (AuthenticatorBase.Java:475) в org.Apache.catalina.core.StandardHostValve.invoke (StandardHostValve.Java:140) в org.Apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.Java:80) в org.Apache.catalina.valves.AbstractAccessLogValve.invoke (AbstractAccessLogValve.Java:624) в org.Apache.catalina.core.StandardEngineValve.invoke (StandardEngineValve.Java:87) в org.Apache.catalina.connector.CoyoteAdapter.service (CoyoteAdapter.Java:341) в org.Apache.coyote.http11.Http11Processor.service (Http11Processor.Java:498) в org.Apache.coyote.AbstractProcessorLight.process (AbstractProcessorLight.Java:66) в org.Apache.coyote.AbstractProtocol $ ConnectionHandler.process (AbstractProtocol.Java:796) в org.Apache.Tomcat.util.net.NioEndpoint $ SocketProcessor.doRun (NioEndpoint.Java:1368) в org.Apache.Tomcat.util.net.SocketProcessorBase.run (SocketProcessorBase.Java:49) в Java.util.concurrent.ThreadPoolExecutor.runWorker (Неизвестный источник) в Java.util.concurrent.ThreadPoolExecutor $ Worker.run (Неизвестный источник) в org.Apache.Tomcat.util.threads.TaskThread $ WrappingRunnable.run (TaskThread.Java:61) на Java.lang.Thread.run (неизвестный источник)

Ниже мой файл pom.xml: (с RestAssured, Hamcrest и JUnit)

<dependencies>
    <dependency>
        <groupId>org.glassfish.jersey.containers</groupId>
        <artifactId>jersey-container-servlet-core</artifactId>
        <!-- use the following artifactId if you don't need servlet 2.x compatibility -->
        <!-- artifactId>jersey-container-servlet</artifactId -->
    </dependency>
    <dependency>
        <groupId>org.glassfish.jersey.media</groupId>
        <artifactId>jersey-media-moxy</artifactId>
    </dependency>
    <dependency>
        <groupId>com.google.code.gson</groupId>
        <artifactId>gson</artifactId>
        <version>2.8.0</version>
    </dependency>
    <dependency>
        <groupId>mysql</groupId>
        <artifactId>mysql-connector-Java</artifactId>
        <version>5.1.6</version>
    </dependency>
    <dependency>
        <groupId>junit</groupId>
        <artifactId>junit</artifactId>
        <version>4.12</version>
        <scope>test</scope>
    </dependency>
    <dependency>
        <groupId>org.hamcrest</groupId>
        <artifactId>hamcrest-all</artifactId>
        <version>1.3</version>
        <scope>test</scope>
    </dependency>
    <dependency>
        <groupId>com.jayway.restassured</groupId>
        <artifactId>rest-assured</artifactId>
        <version>2.9.0</version>
        <scope>test</scope>
    </dependency>
</dependencies>

Ниже мой файл web.xml:

<web-app version="2.5" xmlns="http://Java.Sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://Java.Sun.com/xml/ns/javaee http://Java.Sun.com/xml/ns/javaee/web-app_2_5.xsd">
<servlet>
    <servlet-name>Jersey Web Application</servlet-name>
    <servlet-class>org.glassfish.jersey.servlet.ServletContainer</servlet-class>
    <init-param>
        <param-name>jersey.config.server.provider.packages</param-name>
        <param-value>com.accelbyte.vincent.emailist.resources</param-value>
    </init-param>
    <load-on-startup>1</load-on-startup>
</servlet>
<servlet-mapping>
    <servlet-name>Jersey Web Application</servlet-name>
    <url-pattern>/webapi/*</url-pattern>
</servlet-mapping>

Ниже приведена структура моего проекта: 

Структура проекта списка рассылки

8
Vincent acent

Скорее всего, существует несоответствие версий между ядром Jersey и одной из библиотек расширений Jersey, импортирующих этот класс Binder. Убедитесь, что все связанные с Джерси модули имеют явные версии (и они соответствуют друг другу). Или, что еще лучше, исправьте свои версии, импортировав джерси-бомбу. Например.:

<dependencyManagement>
    <dependencies>
        <dependency>
            <groupId>org.glassfish.jersey</groupId>
            <artifactId>jersey-bom</artifactId>
            <version>2.26-b03</version>
            <type>pom</type>
            <scope>import</scope>
        </dependency>
    </dependencies>
</dependencyManagement>

После чего ваш основной раздел <debendencies> может пропустить версии.

8
andrus_a

Я столкнулся с той же проблемой при использовании разных версий. Убедитесь, что ваши Jersey-bean-validation и Jersey-container-servlet version совпадают.

<dependency>
            <groupId>org.glassfish.jersey.containers</groupId>
            <artifactId>jersey-container-servlet</artifactId>
            <version>2.22</version>
</dependency>
<!-- bean validation -->
<dependency>
    <groupId>org.glassfish.jersey.ext</groupId>
    <artifactId>jersey-bean-validation</artifactId>
    <version>2.22</version>
</dependency>
1
Srikanth Bathi