it-roy-ru.com

ld: библиотека не найдена для -lFirebaseCore clang: error: сбой команды компоновщика с кодом выхода 1 (используйте -v для просмотра вызова)

Я использую react-native-fcm для удаленного Push-уведомления, но он выдает эту ошибку:

ld: библиотека не найдена для -lFirebaseCore clang: error: сбой команды компоновщика с кодом выхода 1 (используйте -v для просмотра вызова)

Pod:

# Uncomment the next line to define a global platform for your project
platform :ios, '9.0'

target 'SefrTaSad' do
  # Uncomment the next line if you're using Swift or would like to use dynamic frameworks
  # use_frameworks!

  # Pods for SefrTaSad

  pod 'Firebase'
  pod 'Firebase/Messaging'

end

Podfile.lock:

PODS:
  - Firebase (5.5.0):
    - Firebase/Core (= 5.5.0)
  - Firebase/Core (5.5.0):
    - Firebase/CoreOnly
    - FirebaseAnalytics (= 5.1.0)
  - Firebase/CoreOnly (5.5.0):
    - FirebaseCore (= 5.1.0)
  - Firebase/Messaging (5.5.0):
    - Firebase/CoreOnly
    - FirebaseMessaging (= 3.1.0)
  - FirebaseAnalytics (5.1.0):
    - FirebaseCore (~> 5.1)
    - FirebaseInstanceID (~> 3.2)
    - GoogleAppMeasurement (~> 5.1)
    - GoogleUtilities/AppDelegateSwizzler (~> 5.2.0)
    - GoogleUtilities/MethodSwizzler (~> 5.2.0)
    - GoogleUtilities/Network (~> 5.2)
    - "GoogleUtilities/NSData+zlib (~> 5.2)"
    - nanopb (~> 0.3)
  - FirebaseCore (5.1.0):
    - GoogleUtilities/Logger (~> 5.2)
  - FirebaseInstanceID (3.2.0):
    - FirebaseCore (~> 5.1)
    - GoogleUtilities/Environment (~> 5.2)
  - FirebaseMessaging (3.1.0):
    - FirebaseCore (~> 5.0)
    - FirebaseInstanceID (~> 3.0)
    - GoogleUtilities/Reachability (~> 5.2)
    - Protobuf (~> 3.1)
  - GoogleAppMeasurement (5.1.0):
    - GoogleUtilities/AppDelegateSwizzler (~> 5.2.0)
    - GoogleUtilities/MethodSwizzler (~> 5.2.0)
    - GoogleUtilities/Network (~> 5.2)
    - "GoogleUtilities/NSData+zlib (~> 5.2)"
    - nanopb (~> 0.3)
  - GoogleUtilities/AppDelegateSwizzler (5.2.2):
    - GoogleUtilities/Environment
    - GoogleUtilities/Logger
    - GoogleUtilities/Network
  - GoogleUtilities/Environment (5.2.2)
  - GoogleUtilities/Logger (5.2.2):
    - GoogleUtilities/Environment
  - GoogleUtilities/MethodSwizzler (5.2.2):
    - GoogleUtilities/Logger
  - GoogleUtilities/Network (5.2.2):
    - GoogleUtilities/Logger
    - "GoogleUtilities/NSData+zlib"
    - GoogleUtilities/Reachability
  - "GoogleUtilities/NSData+zlib (5.2.2)"
  - GoogleUtilities/Reachability (5.2.2):
    - GoogleUtilities/Logger
  - nanopb (0.3.8):
    - nanopb/decode (= 0.3.8)
    - nanopb/encode (= 0.3.8)
  - nanopb/decode (0.3.8)
  - nanopb/encode (0.3.8)
  - Protobuf (3.6.1)

DEPENDENCIES:
  - Firebase
  - Firebase/Messaging

SPEC REPOS:
  https://github.com/cocoapods/specs.git:
    - Firebase
    - FirebaseAnalytics
    - FirebaseCore
    - FirebaseInstanceID
    - FirebaseMessaging
    - GoogleAppMeasurement
    - GoogleUtilities
    - nanopb
    - Protobuf

SPEC CHECKSUMS:
  Firebase: 8c957f9cb3852b519180fb378801b7eeeba4d288
  FirebaseAnalytics: d4a260c114aec0d765ab5b9c404ac63de1d29381
  FirebaseCore: ee4b35cf8c8e781da296cc7c15125e4608bb954d
  FirebaseInstanceID: 8cd2c6cfe7b9ab65ce7e248f6da7f26f6775b9be
  FirebaseMessaging: f67b3719f520ee200da0e20ce577fe2bce0c01d0
  GoogleAppMeasurement: e785bdb86d3d280abc778156cec323a975f11d1d
  GoogleUtilities: 06b66f9567769a7958db20a92f0128b2843e49d5
  nanopb: 5601e6bca2dbf1ed831b519092ec110f66982ca3
  Protobuf: 1eb9700044745f00181c136ef21b8ff3ad5a0fd5

PODFILE CHECKSUM: 5128fcc348aba846d880d9bb9978b4bf02c0718d

COCOAPODS: 1.5.3

я собираю appId, ключ и профиль приложения, успешно подключенного к консоли Firebase, но когда я хочу заархивировать его с помощью xcode, выдается эта ошибка:

enter image description here

enter image description here

как я могу решить эту ошибку?

5
amir hossein

использовать в подфиле 

pod 'Firebase/Core'

после этого перейдите к обновлению терминала

1
Osama Hajjar

Добавьте libRNFirebase.a к своему Linked Framework and Libraries 

1
Ali Sn

В моем случае,

когда команда pod install

pod install показаны желтые предупреждения

  • Используйте флаг $ (унаследованный) или

  • Удалить настройки сборки из целей.


Так что, когда XCode, проект

Проект => Настройки сборки => Пути поиска в библиотеке

добавить $(inherited) нерекурсивным.

тогда проблема решена.

0
Juneho Nam