it-roy-ru.com

YouTube не будет работать после обновления Ubuntu

Поэтому я обновился до прекрасной версии Ubuntu 15.10 Wily Werewolf, и единственная проблема, которую я обнаружил, заключается в том, что YT видео больше не работает, и оно меняет новый видеоинтерфейс на старый для какой-то работы.

12

Поэтому я получаю сообщение об ошибке "Произошла ошибка. Пожалуйста, повторите попытку позже". на новый интерфейс, как вы можете видеть на фотографиях.

Что я могу сделать?

3
123

Для меня это решило установку media.mediasource.webm.enabled в true в about:config

У меня также есть следующие ключи, установленные на true вручную:

  • media.mediasource.enabled
  • media.fragmented-mp4.exposed
  • media.fragmented-mp4.ffmpeg.enabled

Эти настройки позволяют также настроить качество видео (для меня это не работает "из коробки", все доступно только на 360p). Вот полный конфиг, который у меня есть, для справки:

Настройки для media.fragmented * : Settings for media.fragmented*

Настройки для media.mediasource * : Settings for media.mediasource*

4
Zoltan

У меня отлично работает. Я бы предложил настроить YouTube на использование всегда HTML5Если у вас все еще есть проблемы, пожалуйста, добавьте информацию, которую вы получите, нажав "Узнать больше" на ваш вопрос. (Оказывается, больше нет полезной информации.)


Расследование и устранение неисправностей

Я думаю, что смог воспроизвести эту проблему, и до сих пор я не изменял никаких настроек в about: config, как упоминает Золтан, в то время как HTML5-версии YouTube и Vimeo работали нормально для меня. Я только что установил gstreamer1.0-libav, который дал мне это далеко на страница HTML5 YouTube :

enter image description here

Что касается вашего сообщения об ошибке, как я уже говорил, я никогда не изменял связанные параметры в Firefox и не устанавливал никаких расширений или плагинов, которые могли бы изменить их от вашего имени. Вы должны проверить записи, начинающиеся с media. в вашем about: config и вернуть их к значениям по умолчанию с помощью двойного щелчка или контекстного меню → reset. Вы можете или должны оставить настройки media.gmp- в одиночку, затем перезапустите Firefox, и HTML5 YouTube должен работать как положено. Значение максимально близко к значению по умолчанию, когда libav/ffmpeg предоставляет необходимые кодеки.

Эта проблема, кажется, вызвана несовместимой конфигурацией , которая сбивает с толку YouTube, особенно если вы не перезапускаете Firefox, а Flash все еще находится в миксе ( Вы должны ограничить использование Flash и включать его только при необходимости). Другой причиной может быть смешивание контента H.264 и VPx, при котором одно видео будет воспроизводиться, но у другого есть проблемы, которые вызывают сообщение, которое вы получили. Я представляю, что реклама загружается до фактического видео, реклама не будет воспроизводиться, воспроизведение не будет продолжаться и выдается сообщение об ошибке, в то время как фактическое видео воспроизводилось бы просто отлично. Нотабене Я пользователь NoScript и замечаю, что я не вижу столько рекламных роликов, сколько вижу без них.

Воспроизводимо включить все функции видео HTML5

enter image description here

Когда все установлено в состояние по умолчанию (воспроизводимое), вы можете попробовать включить все функции на странице HTML5. Вот как:

Установите gstreamer1.0-libav или последнюю доступную версию пакета, если вы этого еще не сделали. Затем установите для следующих параметров значение true в about: config (текущее значение по умолчанию в Firefox 41 - false):

media.mediasource.enabled;true
media.mediasource.webm.enabled;true
media.fragmented-mp4.exposed;true
media.fragmented-mp4.ffmpeg.enabled;true

Ниже приведены только для проверки, они должны быть включены по умолчанию:

media.gstreamer.enabled;true
media.webm.enabled;true
2
LiveWireBT

Я тоже столкнулся с этой проблемой. YouTube HTML5 дает мне синюю галочку на всех опциях. Если вы воспроизводите видео, то это работает. Однако, если вы отключите webm, то произойдет сбой, как в верхнем посте.

Заглядывая дальше, вы обнаружите, что не удается воспроизвести каждое видео типа "video/mp4", что в основном означает, что декодер h264 распознается (как показано на YouTube), но не работает.

Очевидное решение - включить webm/vp9. Который работает на YouTube (частично), но не все остальное.

Пока что я не нашел решения для всего.

1
Edwin

Принятый ответ не работал для меня. Установка RestrictedFormats как-то помогла:

Sudo apt-get install ubuntu-restricted-extras

После этого по-прежнему появляется сообщение An error occurred. Please try again later, но как минимум видео загружается через секунду или после перезагрузки.

0
Nykakin

о: конфигурации

переключите media.fragmented-mp4.use-blank-decoder в значение true.

Другие настройки: media.mediasource.mp4.enabled для true media.fragmented-mp4. * В true

0
Vsevolod Gromov