it-roy-ru.com

Не удалось разрешить: com.Android.support:support-v4:27.1.1

Я обновил до API 27 и инструменты для сборки. Ранее я использовал API 22.

после обновления до SDK 27 я получил сообщение об ошибке, что мне нужно использовать библиотеку поддержки, аналогичную уровню 27. Я загрузил репозиторий поддержки версии 47.0.0 через SDK manager, и, наконец, это моя настройка gradle. Что я должен сделать, чтобы устранить следующую ошибку:

apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 27
    buildToolsVersion "27.0.3"

    defaultConfig {
        applicationId "com.sample.app"
        minSdkVersion 14
        targetSdkVersion 19
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.txt'
        }
    }
}

dependencies {
    implementation 'com.google.firebase:firebase-messaging:11.0.4'
    compile 'com.google.Android.gms:play-services:11.0.4'
    compile 'com.Android.support:support-v4:27.1.1'
}
apply plugin: 'com.google.gms.google-services'

Ошибка: (23, 13) Не удалось разрешить: com.Android.support:support-v4:27.1.1

2
Ali Sheikhpour

Просто измените название версии зависимости, как показано ниже

dependencies {

        compile 'com.Android.support:design:27.0.2'
        compile 'com.Android.support:support-v4:27.0.2'

        compile 'com.Android.support:appcompat-v7:27.0.2'
        compile 'com.google.Android.gms:play-services-ads:11.8.0'

    }

а также добавить

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}
5
Tahmid Bin Rashid

В вашем проекте build.gradle измените последовательность репозиториев, сделайте google () первым.

allprojects {
    repositories {
        google()
        jcenter()
    }
}
5
Jinqiang Zeng

попробуйте изменить:

apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 27
    buildToolsVersion "27.0.3"

    defaultConfig {
        applicationId "com.sample.app"
        minSdkVersion 14
        targetSdkVersion 27
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.txt'
        }
    }
}

dependencies {
    implementation 'com.google.firebase:firebase-messaging:11.2.0'
    compile 'com.google.Android.gms:play-services:11.2.0'
    compile 'com.Android.support:support-v4:27.1.0'
}
apply plugin: 'com.google.gms.google-services'
0
Dhaval Patel