it-roy-ru.com

Эмулятор: эмулятор: ПРЕДУПРЕЖДЕНИЕ: UpdateCheck: Ошибка: Ошибка

Я смог успешно запустить мой AVD, показанный ниже . avd

Однако после нескольких обновлений API и обновления Android Studio до версии 3.0 я не могу снова успешно запустить AVD. Продолжайте получать ошибку ниже: Ошибка AVD

Мой AVD также очень медленный, и я использую ПК с Windows 8 ГБ ОЗУ.

Ниже приведены подробности моего авт.

Name: Pixel_API_25

CPU/ABI: Google APIs Intel Atom (x86)

Path: C:\Users\Blah\.Android\avd\Pixel_API_25.avd

Target: google_apis [Google APIs] (API level 25)

Skin: pixel

SD Card: 100 MiB

hw.dPad: no

hw.lcd.height: 1920

runtime.network.speed: full

hw.accelerometer: yes

hw.device.name: pixel

vm.heapSize: 256

skin.dynamic: yes

hw.device.manufacturer: Google

hw.lcd.width: 1080

hw.gps: yes

hw.initialOrientation: Portrait

image.androidVersion.api: 25

hw.audioInput: yes

image.sysdir.1: system-images\Android-25\google_apis\x86\

tag.id: google_apis

showDeviceFrame: yes

hw.camera.back: emulated

hw.mainKeys: no

AvdId: Pixel_API_25

hw.camera.front: emulated

hw.lcd.density: 480

avd.ini.displayname: Pixel API 25

hw.gpu.mode: auto

hw.device.hash2: MD5:524882cfa9f421413193056700a29392

hw.ramSize: 1024

hw.trackBall: no

PlayStore.enabled: false

fastboot.forceColdBoot: no

hw.battery: yes

hw.cpu.ncore: 2

hw.sdCard: no

tag.display: Google APIs

runtime.network.latency: none

hw.keyboard: yes

hw.sensors.proximity: yes

disk.dataPartition.size: 800M

hw.sensors.orientation: yes

avd.ini.encoding: UTF-8

hw.gpu.enabled: yes

Пожалуйста помоги.

6
tobbyioa

Вы должны удалитьHAXMи переустановить его, убедитесь, что для него выделено как минимум 2 ГБ оперативной памяти. и когда вы создаете эмулируемое устройство, дайте ему меньше, чем вы далиHAXMя бы сказал 1 ГБ, что должно ускорить процесс. но я хотел бы предложить вам больше RAM 8 ГБ мало. Моя система использует 10 ГБ с Google Chrome, Android Studio и открытым эмулятором. При переходе на новую версию вы также должны перейти в Файл> Неправильные кэши/Перезапустить  

3
Mihai

У меня была та же проблема с Android Studio 3.0.1, пытался следовать выше, но не работал.

Странно изменив цель с «Open Select Deployment Target Dialog» на «Emulator» в «Run/Debug Configurations», эта проблема была устранена.

Тестовое приложение установлено. После успешной установки я вернул назад. Цель все еще работает.

1
SMa

Может быть, ваше ч/б ускорение отключено. Вы должны попробовать включить ускорение ч/б через BIOS. Это может помочь с медленной скоростью.

0
shubham jadhav

Убедитесь, что у вас стабильное интернет-соединение с выбранными вами настройками прокси. Мои корпоративные настройки прокси вызвали эту ошибку. 

0
Onat Korucu

Я перепробовал все, но не сработало .. В конце вы должны удалить эмулятор и создать новый следующим образом:

по этому пути C:/user/username/.Android/avd удалите папку и перезапустите IDE, затем создайте новый эмулятор.

0
Mustafa Shahoud