it-roy-ru.com

Как обновить libavcodec на Ubuntu 14.04?

В Ubuntu 14.04.5 я только что обновил Firefox до версии 50.0; теперь на некоторых страницах есть сообщение, которое гласит:

libavcodec may be vulnerable or is not supported, and should be updated to play videos

Так как я могу обновить libavcodec?

Просто

Sudo apt-get install libavcodec

дает следующий вывод:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libavcodec

Так, может быть, я не установил libavcodec во-первых? Так почему я получаю это сообщение ...?

45
Alex

Просто включите libavcodec в firefox:
введите about:config в адресной строке, enter
нажмите "Я принимаю риск" поиска libavcodec
измените media.libavcodec.allow-obsolete;false на true

enter image description here

38
user3317398

Обновление

libavcodec был обновлен в Ubuntu 14.04.

Обновление libav-tools, libavcodec-extra и libavcodec-extra-54 в Ubuntu 14.04 решило проблему. Уведомление libavcodec may be vulnerable or is not supported, and should be updated to play video больше не появляется после обновления системы с помощью Software Updater.


В Ubuntu 14.04 я использую Firefox 50 из репозиториев Ubuntu по умолчанию, который является последней версией Firefox на момент написания этой статьи. У меня не установлен пакет libavcodec в этой системе, потому что мне не нужно его устанавливать. Если у вас не установлен пакет libavcodec, вы можете проигнорировать вторую часть этого ответа.

Я получаю уведомление libavcodec may be vulnerable or is not supported, and should be updated to play video. при попытке воспроизвести видео, размещенное на Facebook, и видео с других сайтов, таких как cnn.com и yahoo.com. Я решил проигнорировать это уведомление и не обновлять мой libavcodec, потому что те же видео воспроизводятся идеально, без отображения уведомления libavcodec в веб-браузере Chromium на тех же проигрывателях. Единственное различие в видео между Firefox и Chromium, которое я заметил, заключается в Chromium. Я вижу дополнительные опции для изменения качества видео при нажатии на значок шестеренки видеоплеера Facebook, который я не вижу в Firefox.

enter image description here
обновить уведомление libavcodec в Firefox 50, когда libavcodec не установлен

Уведомление на скриншоте выше немного сбивает с толку, поскольку видео на этой веб-странице воспроизводится нормально, даже если libavcodec не установлен. Похоже, что уведомление приходит от Firefox, потому что такое же уведомление отображается на Facebook и CNN. Нужно ли перетаскивать другой PPA, чтобы избавиться от надоедливого уведомления libavcodec в Firefox, даже если в Firefox видео воспроизводится нормально? Это же видео отлично воспроизводится в Chromium, без каких-либо уведомлений об обновлении libavcodec.

После того, как вы обновите Firefox до версии 50 (без установленной libavcodec54) и начнете воспроизводить видео, вам может быть предложено разрешить и запомнить Firefox, чтобы запустить плагин мультимедиа для того, чтобы видео начало воспроизводиться.


Установить libav-tools (мультимедийный проигрыватель, кодировщик и транскодер) libavcodec56 (библиотека кодеков Libav) и libavcodec-extra-56 (библиотека кодеков Libav (дополнительные кодеки)) в Ubuntu 14.04, откройте терминал и введите:

Sudo add-apt-repository ppa:heyarje/libav-11
Sudo apt-get update
Sudo apt-get install libav-tools libavcodec-extra-56
Sudo apt-get upgrade
18
karel

Ради тех, кто пришел сюда из Google, я также разместил этот ответ для супер-пользователя: https://superuser.com/questions/1137029/libavcodec-may-be-vulnerable-message-in-firefox/1148770 # 114877

ответ Карела сработает, если вы в порядке установки другого репо, и пользователь 3317398, если у вас все в порядке с уязвимостью безопасности.

Если, как и я, вас не волнует, что некоторые видео не воспроизводятся, и вы просто хотите, чтобы это чертово сообщение исчезло - без отключения libavcodec ( потому что ручное отключение означает, что я должен был бы вручную повторно включить, как только исправление выйдет) - тогда вы должны перейти к about:config и искать:

media.decoder-doctor.notifications-allowed

В поле значения вы можете увидеть список значений через запятую; тот, который вы хотите удалить, MediaUnsupportedLibavcodec. Например, моя настройка была:

MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight,MediaUnsupportedLibavcodec

И я изменил это на:

MediaWMFNeeded,MediaWidevineNoWMFNoSilverlight

Виола! Нет больше надоедливых уведомлений, и видео, для которых требуется кодек, не будет работать. Тем не менее, здесь нет проблем с безопасностью, и как только официальное репо выдвинет исправление, видео снова начнет работать без каких-либо дополнительных усилий с вашей стороны.

9
cegfault

К вашему сведению - Ubuntu 12.04 LTS тоже затронут. Пожалуйста, не голосуйте.

На Launchpad у нас есть ошибка 1643467 о проблеме с libav и Firefox.

Я нашел PPA с более новой libav (версия 11.2-1ppa1) для Precise:

Sudo add-apt-repository ppa:itachi-san/ffmpeg
Sudo apt-get update
Sudo apt-get install libav-tools libavcodec56

Если вы не хотите устанавливать libav из PPA, вы можете установить media.libavcodec.allow-obsolete в true в about:config, как 14.04 LTS.

6
N0rbert

У меня была такая же проблема после обновления. Я сделал это и работал на меня:

Sudo add-apt-repository ppa:heyarje/libav-11
Sudo apt-get update
  1. откройте менеджер пакетов Synaptic.
  2. поиск в фильтре о libavcodec.
  3. установите флажок libavcodec-extra и примените.

synaptic manager

5
Tarek