it-roy-ru.com

Как исправить проблему с пакетом, которую я получил после неудачной попытки установки QtOctave?

Я установил GNU Octave 3.6.4 сегодня сразу после того, как он был выпущен с помощью команд:

cd ~/octave-3.6.4
./configure
make
Sudo make install
Sudo ln -s /home/brentonhorne/octave-3.6.4/run-octave /usr/bin/octave

который удалось установить (хотя без последней строки это не означало, что запуск octave из командной строки не вызывал его).

Я сделал это после того, как удалил предыдущую версию, которая в настоящее время является единственной версией, доступной в центре программного обеспечения на Quantal (т. Е. GNU Octave 3.6.3).

Затем я попытался установить qtoctave, потому что он был удален с помощью GNU Octave 3.6.3 при запуске Sudo apt-get remove octave. После запуска Sudo apt-get install -f я получил ошибку:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up octave (3.6.3-2~ppa1~quantal2) ...
error: couldn't read directory /usr/local/share/octave/packages: No such file or directory
error: called from:
error:   /usr/local/share/octave/3.6.4/m/pkg/pkg.m at line 541, column 7
error:   /usr/local/share/octave/3.6.4/m/pkg/pkg.m at line 472, column 25

dpkg: error processing octave (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for menu ...
Errors were encountered while processing:
 octave
E: Sub-process /usr/bin/dpkg returned an error code (1)
2
BH2017

Будьте осторожны, это может повредить вашу установку!

Найдите пакет, который установлен неправильно, и скопируйте или запомните имя пакета:

Sudo dpkg --list | grep octave

Попробуйте удалить его (возможно, некоторые ошибки):

Sudo dpkg --remove <package>

Попробуйте очистить

Sudo dpkg --purge <package>

Попробуйте сделать Sudo apt-get -f install снова.

5
prophecy201