it-roy-ru.com

Неудовлетворенные зависимости в Ubuntu 12.04?

The following packages have unmet dependencies:
       gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7-1) but    4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                         Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                         Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                         Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                         Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                         Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed gstreamer0.10-ffmpeg:i386:    Depends: libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to   be installed
                              Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                              Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                              Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                              Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                              Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                              Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed



       Package dependencies cannot be resolved
       This error could be caused by required additional software packages    which are missing or not installable. Furthermore there could be a    conflict between software packages which are not allowed to be    installed at the same time.

Я пытался следовать каждой инструкции от здесь , и это все еще не помогло мне.

В чем проблема и как ее исправить?

Edit:
Моя проблема в том, что я не могу установить кодеки видео-плагинов Gstreamer ffmpeg для воспроизведения файлов .mpeg, .divx, .mpeg4, .ac3, .wmv и .asf

4
santosamaru

Вы, кажется, используете очень устаревшие библиотеки, например, "libavcodec-extra-53 (> = 4: 0.7-1), но 4: 0.7.2.1ubuntu2 должен быть установлен". Эта версия была выпущена в 12.04 dev 2011-12-26 и неоднократно заменялась.

Текущая версия 12.04 - 4: 0.8.3ubuntu0.12.04.1) точная защита

Итак, откройте исходные коды программного обеспечения software-properties-gtk и убедитесь, что в Ubuntu Software первые 4 проверены и в Updates первый. 2 проверены

Тогда обновите свои источники и посмотрите

4
doug